
 

 

What’s New 

Sage UBS version 9.9.5.1  

Release Date:   

15th October 2020 

 

Important Note 

• You will need to disable your Anti-virus before you install the new update as some Anti-virus can interfere and 

prevent a successful installation. 

• After successfully installing the update (whether via Online Update or using the Installer), you must restart your 

computer for the configuration changes to take effect. 

 

V9.9.5.1 Updates 

The following enhancements are being released: 

 

 

Payment Cloud/Invoice Payments 

• AsiaPay 
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Payment Cloud/Invoice Payments 

In this challenging time, many businesses today are looking out for opportunities to get paid faster on the sales made. Sales 

without prompt collections will put any businesses into a negative cashflow position which will pose a threat on the business 

financial health check. And, to enable their customers can make payment effortlessly, ease, convenience and flexibility are the 

key factors that will help to drive this push. 

In the effort of making payments seamless we have provided new features in Sage UBS to assist our users in better collection 

and their customers to make payment easily and conveniently, with the following capabilities: 

a. Ability to email invoices directly to customers with a payment link where they can conveniently click to make payments 

with various methods  

b. Provide several service providers choices for Sage user to go onboard and start using the facility to ease collection in a 

matter of minutes 

 

 

1. Customer Journey 
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2. How it works 

 

 

Important Note: This function is tied to your Sage Cover Validation. If your Sage Cover is valid, it will be made available in 

the system for your use.   
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3. Getting started 

Note: The Payment feature can only be onboarded up to 20 times per license. E.g. You have 40 companies created but 

only 20 companies can be onboarded. 

3.1 Welcome message 

At the login page, users will see a pop-up welcome message introducing the new Invoice Payment feature with contact 

information for Sage to assist our users should they require more information 

 

 

 

3.2  New labels  

To provide better visibility when logging in to Sage UBS, labels indicating the new features are provided so 

that users can navigate through the menus easily to find those said features. 

3.2.1 Accounting 

1. Services 
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  2. Services > Invoice Payment Listing 

 

 

3.2.2 Inventory & Billing 

 1. Administration 

 

 2. Administration > Administrative Tools 

 

3. Administration > Administrative Tools > E-Banking 
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3.3  AsiaPay 

In this release, Sage UBS is offering AsiaPay as an additional payment provider besides the existing payment providers 

(PayPal, Stripe) 

 

3.4 AsiaPay Onboarding process 

As this function is related to invoice payment, the onboarding process will be done only at the Inventory & Billing module. 

3.4.1 Steps 

Module →  Inventory & Billing 

Path  →  Administration > Administrative Tools > E-Banking tab 

Action  →  Select AsiaPay  

 → Click on “Set up Payment Provider” button to start the onboarding process 

 

 

3.4.2  Disclaimer 

Disclaimer for users:  
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3.4.5 AsiaPay 

  1)Select AsiaPay and click on “Set up Payment Provider”  

 

 

 2) Click on “Set up now!”  to sign in to your merchant account. 
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1) Fill in your credentials and click OK. Finish setup. 

 

 

3.5  Set up after Onboarding 

Once onboarding is successful, users will be redirected back to the Administrative Tools screen where you will be required 

to perform the necessary settings in Administrative Tools > E-Banking to manage your tasks efficiently.  

 

3.5.1  Payment Providers Management 

 
 

Note: This section is for user to view all Payment Services Providers that were successfully activated. Multiple Payment 

Providers can be activated at the same time or over a period; but only 1 can be in-use at a time. This is to ensure 

the correct payment link is generated for the invoice you will email to your customer. 
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Tab / Feature Function 

Payment Providers Management • Payment Service Providers successfully activated will be listed here for 

user to manage settings as required on the right panel: 

➢ Bank Acc • map the relevant GL bank account here for the system to update when 

you generate receipt from the payment status screen 

➢ Bank Charges Acc • map the relevant GL account here for the system to update charges 

incurred, where applicable, when you generate receipt from the 

payment status screen 

➢ Status • to see which payment service is active 

➢ In Use • check the box to set default payment service to use in the Pay link 

 

 

3.5.2  Payment Link Settings 

 

 

Note: This section is for you to link list of customers to the respective payment service you have activated. Some 

businesses may want to separate different categories of customers to pay under different payment provider and 

this can be easily addressed by checking on the check box to link the customers to the payment provider 

accordingly.    
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Tab / Feature Function 

Payment Link Settings • to link your customers to the relevant payment service provider for the 

payment link generation. 

Note: Only customers that are selected (checked) will have the Pay 

link embedded in the email received 

➢ Checkbox • Customers maintained in the system will be listed here for user to mark 

/ unmark as per business needs 

Note: Only marked customers will have the payment link 

generated and embedded in the email sent to them for direct 

payment processing  

 

  

3.6  Email Invoice with payment link 

With the current email function in place, we have integrated the payment feature to include the payment link in the 

email itself. This feature is only functional when payment service is active and in-use. As mentioned earlier, this function 

is related to invoice payment and the emailing of invoice will be processed at the Inventory & Billing module 

3.6.1  Select an invoice to email 

- Customer & Sales > Sales Invoices > Create Invoice / Search Invoice 

- Create a new invoice or select a pre-existing invoice  

- Click on the ‘Mail’ icon to bring up the email window 
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3.6.2  Email the Invoice with payment link 

- Check to ensure the option “Include Payment Link” is checked. It is checked by default when feature is active. 

Note: Checkbox can be unchecked by user if payment link is not required in the invoice to be emailed. 

- Click ‘Send’ button to send the email with payment link.  

 

 

 

3.6.3  Resending Email with updated info 

- Updated info will not be shown if you resend an email until you cancel the previous email. 

- Example: An email with payment link has been sent out, you make changes to that invoice, you will need to cancel 

the previous invoice before sending out the updated version. 
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3.7  Get Paid 

The flow explained on this section will be handled by your end-customers once they receive the email from you. 

3.7.1  Check email (Customer side) 

Email received by customer will be similar to the screen below: 

 

 

 

3.7.2  Making payment (Customer side) 

To make payment, customer will click on the green ‘Pay’ button in the email. This button has the embedded link which 

will direct the customer (payer) to the AsiaPay payment service website to make the payment online. 
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Important Notes for your end-customers when making invoice payment 

1. Chrome Browser 

If your end-customer is using Chrome browser to access the payment gateway to make 
payment, he may encounter a glitch where the transaction result appeared for a split second 
and gets redirected to an error message screen as shown below.  

 

AsiaPay is aware and in the process of resolving this behaviour in Chrome. Other browsers 
ie. Internet Explorer, Edge, Firefox and Safari are confirmed working fine. 

2. Unusable payment link when exiting a payment session midway 

If your end-customer is using GrabPay or FPX payment method to make the invoice 
payment and happened to close the tab/window midway without completing the transaction, 
the payment link will not be usable anymore as the session was not properly closed.  

If your end-customer clicks on the payment link again, he will encounter an error message 
prompt “Duplicate merchant reference no.” as shown below and will not be able to proceed. 

 

To ensure your end-customer can proceed to make the invoice payment, you may first have 
to cancel the previous payment link. Then resend the email with new payment link to your 
end-customer to make a fresh new payment on the invoice. 

3. Payment portal will record “Rejected” status when a PAID link is being clicked again 

If your end-customer happens to click on a payment link that has been processed (PAID), 
an error message “Duplicate merchant reference no.” will be prompted and he will not be 
able to proceed further. 

However, when you check the AsiaPay payment portal, you will notice AsiaPay does keep 
record of that failed transaction under the status “Rejected” with same reason provided as 
per sample shown below: 

 

Please do not be alarmed as this record is just information for your easy reference and 
tracking should your end-customer call on you to check if payment has been processed.   
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3.8  Check Status  

After you have sent out the email, you may check on the payment status later at our new Invoice Payment Listing function to 

get the latest updates on the payments. 

 

3.8.1 Invoice Payment Listing 

We have added a new dashboard feature in Accounting module to allow users to view all the related invoices and provide 

comprehensive and updated information on payment statuses. Note: Checking of statuses will be handled in Accounting 

module as the issuing of receipt, knock-off process and AR updates are all managed here.  

Path → Services > Invoice Payment Listing 

 

 

 

Notes:  

1. In the bottom left corner of the window shows the last updated date and time.  

2. To view new incoming invoices, user must refresh the list.  

3. To refresh the list, user must close the window and reopen it. This step is required to download the latest updates 

 

 

Functions & Features  

• View details of 

invoices 

➢ such as date created, invoice no., amount, status etc. 

• View invoices with 

different status 

➢ by clicking on the status dropdown list and select a different status type and click 

on ‘Show Listing’ button to show the new list 

• Filters ➢ to view or sort invoices by date range, customer/debtor number, invoice number, 

status, and payment service provider 

• View status change ➢ For example, when a user sends out an email with payment link, the status will be 

shown as Pending, and once payment is made, status will change to Paid 

• Cancel payment ➢ by selecting an invoice and click on ‘Cancel Payment’. This will make the sent 

payment link unusable 

• Generating receipts ➢ User can generate receipts by selecting a paid invoice and click on ‘Generate 

Receipt’ 
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Examples of statuses and what they mean: 

 

 

Status type Description 

ALL Show all invoices 

PAID Show invoices that have been successfully paid 

PENDING Show invoices that have been sent out successfully but have not been paid. 

FAILED Show invoices that have failed to send. 

CANCELLED Show invoices that have been sent and then cancelled. 

REFUNDED Show Invoices that have been refunded. 

PARTIALLY_REFUNDED Show invoices that have been partially refunded. 

 

 

Update 

It is important to know that the payment made is processed and handled by the Payment Service Provider outside of 

our system. However, with the ability to pull updates information back to the system, you will be able to proceed to 

update the payment into your accounts by generating the receipt to your customer in the Accounting module.  
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3.8.2 Generate Receipts 

All payments with status “PAID” will have the Generate Receipt function enabled on the bottom of the page. Simply 

click on the button and it will direct you to the receipt screen to process your receipt accordingly 

- Select “PAID” status and invoices that have been paid by customers via the Pay link will be displayed 

- Select a record and click Generate Receipt button to issue receipt to your customer on the paid invoice 

 

 

- System will direct you to the Receipt screen with auto-filled information from the payment link: 

1. Bank A/c No. and Name (only if mapping is done at the setup) 

2. Amount 

3. Debtor A/C No. and Name 

- User is required to manually enter other necessary information like Batch no., Reference number, including Bank 

A/C No. if field is blank due to incomplete mapping at setup 

- After filling in all required fields, user can then click on the Knock-Off button to proceed with the receipt-invoice 

offset process  
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- Once the knock-off process is done, the knock-off details will be displayed on the grid section for your reference 

- Click on the Reverse button to undo the knock-off link between the receipt and invoice 

- Click on ‘Save’ button to save the receipt after verifying all information is correct.  

Note: at this point, your financial entries will be auto generated, and GL accounts updated simultaneously 

 

 

  



Sage UBS v9.9.5.1  ◄19 
   

191919  

 

3.8.3 Edit Receipts 

Users can still edit the saved receipt by going back to the Invoice Payment Listing screen and select the receipt listed 

in the Receipt column. Click on ‘Edit Receipt’ button to be directed to the receipt screen to make the necessary 

changes and save the receipt again. 

 

 

 

 

******   End   ****** 

 


